Office 365 Outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Jun 30, 2023 - 09:46 EDT
Identified
SAU IT is investigating an outage at Microsoft that is preventing a few people from opening their email through the web version of Outlook. If you receive an error (error message 500) while opening your email in a web browser please let us know by emailing helpdesk@arbor.edu. This outage is impacting people outside SAU as well (https://downdetector.com/status/microsoft-365/)
Posted Jun 27, 2023 - 15:14 EDT
This incident affected: Email & Calendar (Office 365).