Andrews Hall WiFi
Incident Report for Spring Arbor University
Resolved
Patching is completed.
Posted Sep 18, 2017 - 10:02 EDT
Monitoring
Andrews Hall WiFi will go offline for updates and patching for 10 minutes between 9:55 AM and 10:15 AM.
Posted Sep 18, 2017 - 09:54 EDT