Scan to email outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 21 days ago. Mar 28, 2019 - 12:06 EDT
Monitoring
This issue is now resolved, we are monitoring to see if there are any more issues.
Posted 21 days ago. Mar 28, 2019 - 09:39 EDT
Investigating
Information Technology is currently investigating an outage with scan to email services from printers on SAU's main campus.
Posted 22 days ago. Mar 28, 2019 - 09:03 EDT
This incident affected: Spring Arbor Campus (Printing).