CARS issues
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 14:45 EST
Investigating
SAU IT is investigating an issue that is preventing some staff members from connecting to CARS.
Posted Dec 04, 2023 - 13:12 EST
This incident affected: CARS / MySAU Portal (CARS / Jenzabar CX).