Campus power issues
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Aug 25, 2023 - 20:12 EDT
Update
Consumers Energy is expecting power to be restored to these locations by 4:15pm today.
Posted Aug 25, 2023 - 10:14 EDT
Identified
Network and WiFi access are unavailable in several buildings due to power outages related to a storm last night. Currently there is no power or network in the Fieldhouse, most of the villages, the apartments, Lowell, the marketing house, the M&D House, the Campus Safety house, and many other khouses.
Posted Aug 25, 2023 - 09:00 EDT
This incident affected: Spring Arbor Campus (Internet Connectivity).