Box Outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 17:45 EST
Identified
Box is reporting an outage that is impacting their services. At this time, some of their systems are not accessible. The most up to date information is available at status.box.com.
Posted Jan 09, 2024 - 14:43 EST
This incident affected: Box (Box Sync, Box Website, Box Search).