Degraded performance: Internet in third floor of poling center
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Apr 09, 2018 - 14:27 EDT
Identified
Information services is investigating an internet outage in the third floor of Poling.
Posted Apr 09, 2018 - 14:10 EDT